Skip to content
Feature RequestOtherOpen

Proper DNS record support

Currently the DNS Records are… Rather lacking and are missing about half of the entire standard suite of record types, which is rather disappointing. Adding them should be relatively easy as whatever DNS resolver you are using under the hood already supports them. They just need to get added to the Zap UI. I can get why HTTPS and SVCB aren't here, as they are relatively new, but the rest? CAA - RFC 6844 CERT - RFC 4398 LOC - RFC 1876 NAPTR - RFC 3403 OPENPGPKEY - RFC 7929 SMIMEA - RFC 8162 SSHFP - RFC 4255 TLSA - RFC 6698 -> https://www.knot-resolver.cz/documentation/latest/rfc-list.html

Originally posted by WilliDieEnte on our previous feedback board.

Ffeaturebase-import17 Jun 2026

Comments (1)

ZAP
Official response
28 Sep 2026, 17:40

ZapX DNS management now supports CAA, SSHFP and TLSA records in addition to the usual types. CERT, LOC, NAPTR, OPENPGPKEY and SMIMEA aren't supported yet, so we're keeping this open.

Log in to comment.

Timeline

All important changes at a glance.

Official response from the ZAP team added.

From ZAP

28 Sep 2026

17:40

Feedback

Do you have another suggestion?