Suporte adequado para registros DNS
Atualmente, os registros DNS estão... bastante deficientes e faltam cerca de metade de toda a suíte padrão de tipos de registros, o que é bastante decepcionante. Adicioná-los deve ser relativamente fácil, já que qualquer resolvedor DNS que você estiver usando em segundo plano já os suporta. Eles só precisam ser adicionados à interface do usuário do Zap. Eu consigo entender por que HTTPS e SVCB não estão aqui, pois são relativamente novos, mas o resto? CAA - RFC 6844 CERT - RFC 4398 LOC - RFC 1876 NAPTR - RFC 3403 OPENPGPKEY - RFC 7929 SMIMEA - RFC 8162 SSHFP - RFC 4255 TLSA - RFC 6698 -> https://www.knot-resolver.cz/documentation/latest/rfc-list.html
Publicado originalmente por WilliDieEnte no nosso antigo quadro de sugestões.